Ratelimit aktiv für Microsoft (hotmail.com, outlook.com, ...) auf diversen Mailserver

Incident Report for Webland

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 08:26 CET

Update

Das rate-limit für MS06 wurde am 01.03.2026 um 21:06 von Microsoft entfernt. Die Anzahl an E-Mails in der "retry"-Wiederversuche Warteschlange ist wieder auf einer normalen Anzahl.
Somit sind alle Server wieder im normalbetrieb.

Ein Statement von MIcrosoft haben wir seither nicht erhalten.

---

The rate limit for MS06 was removed by Microsoft on 01.03.2026 at 21:06. We see a normal amount of retry Mails in the mailqueue.
Hence all mail servers are back to normal operation.

Until now, we haven't received a statement from Microsoft regarding this issue.
Posted Mar 02, 2026 - 09:17 CET

Update

Seitens Microsot wurde eine Mitigation auf den Servern MS1, MS2, MS3, MS4, MS7, MS8 und MS9 vorgenommen.
MS6 ist noch im rate-limit.
Wir versuchen weiterhin, Kontakt mit Microsoft bezüglich MS6 aufzunehmen. Wir hoffen auf ein baldiges Feedback und Delisting.

---

Microsoft has implemented a mitigation on servers MS1, MS2, MS3, MS4, MS7, MS8 and MS9.
However, MS6 is still subject to rate limiting.
We are still trying to get in touch with Microsoft regarding MS6. We hope that we will receive feedback and a delisted soon.
Posted Feb 26, 2026 - 09:35 CET

Monitoring

Leider haben wir noch kein Feedback erhalten von Microsoft.
Von der Sperrung sind wir nicht einzig* betroffen. Wir gehen daher davon aus, dass es eine Anpassung bei Microsoft gab.

Leider können wir aktuell nur abwarten bis eine Anpassung seitens Microsoft erfolgt, welche das rate-limit aufhebt.

Sobald wir weitere Informationen haben, werden wir diese auf der Statuspage bereitstellen.

---

Unfortunately, we haven't yet received any feedback from Microsoft.
We are not the only ones* affected by the block. We therefore assume that Microsoft has made an adjustment.

Unfortunately, we can only wait until Microsoft makes an adjustment that removes the rate limit.

As soon as we have further information, we will post it here on the status page.

*Quellen/Source:
- https://learn.microsoft.com/en-us/answers/questions/5786144/all-sending-ips-temporarily-rate-limited-(451-4-7
- https://borncity.com/blog/2026/02/25/e-mail-zustellprobleme-an-hotmail-25-feb-2026/
Posted Feb 25, 2026 - 17:47 CET

Identified

Seit dem 23.02.26, 20:05 vermerken wir diverse Mailserver, welche bei Microsoft auf einer Internen "Blacklist" sind. Dies hat zur folge, dass nur eine gewisse Anzahl an E-Mails an Microsoft gesendet werden kann, bis das "rate limit" weitere Zustellversuche blockiert. Dadurch werden die E-Mails verzögert oder aufgrund der angehäuften Warteschlange nicht zugestellt.
Dies betrifft E-Mail-Empfänger wie "hotmail.com" und "outlook.com" und regionsspezifische Domains.

Davon aktuell betroffene Mailserver sind: MS1, MS2, MS3, MS4, MS6, MS7, MS8 und MS9

Unser Vorgehen sieht vor, dem Ursprung der Meldung nachzugehen und nach Behebung bei Microsoft ein "delisting" zu beantragen.
In den letzten Wochen ist dies aussergewöhnlich oft vorgekommen. Bei den vorangehenden Fällen konnten wir eine verschlechterte Antwortzeit seitens Microsoft feststellen.
Dies haben wir ebenfalls bereits bei anderen Anbietern vermerkt und gehen daher von einer Anpassung der Schwellwerte seitens Microsoft aus.

Aktuell warten wir auf Rückmeldung seitens Microsoft und hoffen auf ein baldiges Feedback bezüglich des "ratelimits" und des "delisting" Verfahren.

---

Since 23.02.26, 20:05, we have noticed several mail servers which got blacklisted by Microsoft. As a result, only a certain number of emails can be sent to Microsofts servers before the ‘rate limit’ blocks further delivery attempts. This causes emails to be delayed or not delivered at all because of the mail queue.
This affects email recipients such as ‘hotmail.com’, ‘outlook.com’ and region-specific domains.

Currently these mail servers are affected: MS1, MS2, MS3, MS4, MS6, MS7, MS8 and MS9

Our default approach is to investigate the source of the blockage and, once it has been resolved, to request a ‘delisting’ at Microsofts site.
This has occurred with unusual frequency in recent weeks. At the previous cases, we have noticed a deterioration in response times on the part of Microsoft.
We have also noted this with other providers and therefore assume that Microsoft is adjusting the threshold values.

We are currently awaiting a response from Microsoft and hope to receive feedback soon regarding the rate limit and the delisting procedure.
Posted Feb 24, 2026 - 18:18 CET
This incident affected: E-Mail Server.